PYSEC-2020-176
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-20477
- Alias
- GHSA-3pqx-4fqf-j49f
Description
PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pyyaml | introduced 5.1, fixed 5.2b1 |
Références
- https://www.exploit-db.com/download/47655 WEB
- https://github.com/yaml/pyyaml/blob/master/CHANGES WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/52N5XS73Z5S4ZN7I7R56ICCPCTKCUV4H/ WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/33VBUY73AA6CTTYL3LRWHNFDULV7PFPN/ WEB
- https://github.com/advisories/GHSA-3pqx-4fqf-j49f ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |