PYSEC-2020-11

At a glance

Published
Updated
CVE
CVE-2020-1739
Aliases
GHSA-923p-fr2c-g5m2

Description

A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.7.17, introduced 2.8.0, fixed 2.8.9, introduced 2.9.0, fixed 2.9.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database