PYSEC-2019-4
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-14846
- Alias
- GHSA-pm48-cvv2-29q5
Description
In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG level which lead to a disclosure of credentials if a plugin used a library that logged credentials at the DEBUG level. This flaw does not affect Ansible modules, as those are executed in a separate process.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 0, fixed 2.6.20, introduced 2.7.0, fixed 2.7.14, introduced 2.8.0, fixed 2.8.6 |
Références
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14846 REPORT
- https://github.com/ansible/ansible/pull/63366 WEB
- https://access.redhat.com/errata/RHSA-2019:3207 ADVISORY
- https://access.redhat.com/errata/RHSA-2019:3201 ADVISORY
- https://access.redhat.com/errata/RHSA-2019:3202 ADVISORY
- https://access.redhat.com/errata/RHSA-2019:3203 ADVISORY
- https://access.redhat.com/errata/RHSA-2020:0756 ADVISORY
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html WEB
- https://lists.debian.org/debian-lts-announce/2020/05/msg00005.html WEB
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html WEB
- https://github.com/advisories/GHSA-pm48-cvv2-29q5 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |