PYSEC-2019-3

En bref

Publiée
Mise à jour
CVE
CVE-2019-10217
Alias
GHSA-p75j-wc34-527c

Description

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.8.0, fixed 2.8.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database