PYSEC-2019-2

At a glance

Published
Updated
CVE
CVE-2019-10156
Aliases
GHSA-grgm-pph5-j5h7

Description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.6.18, introduced 2.7.0, fixed 2.7.12, introduced 2.8.0, fixed 2.8.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database