PYSEC-2018-39

En bref

Publiée
Mise à jour
CVE
CVE-2016-9587
Alias
GHSA-m956-frf4-m2wr

Description

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.1.4.0, introduced 2.2.0.0, fixed 2.2.1.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database