PYSEC-2018-38

En bref

Publiée
Mise à jour
CVE
CVE-2016-8628
Alias
GHSA-jg4f-jqm5-4mgq

Description

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.2.0.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database