GHSA-xxp4-mf4h-6cwm

Moodle vulnerable to Server Side Request Forgery

En bref

Publiée
Mise à jour
CVE
CVE-2023-35133
Alias
BIT-moodle-2023-35133
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

An issue in the logic used to check 0.0.0.0 against the cURL blocked hosts lists resulted in an SSRF risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 4.2.0, fixed 4.2.1
Packagist · moodle/moodleintroduced 4.1.0, fixed 4.1.4
Packagist · moodle/moodleintroduced 4.0.0, fixed 4.0.9
Packagist · moodle/moodleintroduced 3.10.0, fixed 3.11.15
Packagist · moodle/moodleintroduced 0, fixed 3.9.22

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database