GHSA-xvw9-3mhm-xjqq

Apache Airflow information disclosure vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2022-46651
Alias
BIT-airflow-2022-46651, PYSEC-2023-103
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.6.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database