GHSA-xvqc-pp94-fmpx

Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT vulnerable to Integer Overflow or Wraparound

En bref

Publiée
Mise à jour
CVE
CVE-2026-40046
Alias
BIT-activemq-2026-40046
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Description

Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT. The fix for "CVE-2025-66168: MQTT control packet remaining length field is not properly validated" was only applied to 5.19.2 (and future 5.19.x) releases but was missed for all 6.0.0+ versions. This issue affects Apache ActiveMQ: from 6.0.0 before 6.2.4; Apache ActiveMQ All: from 6.0.0 before 6.2.4; Apache ActiveMQ MQTT: from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or a 5.19.x version starting with 5.19.2 or later (currently latest is 5.19.5), which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.activemq:apache-activemqintroduced 6.0.0, fixed 6.2.4
Maven · org.apache.activemq:activemq-allintroduced 6.0.0, fixed 6.2.4
Maven · org.apache.activemq:activemq-mqttintroduced 6.0.0, fixed 6.2.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database