GHSA-xp2f-9mx3-3c6p
Moodle PostScript Code Injection
At a glance
- Published
- Updated
- CVE
- CVE-2022-35649
- Aliases
- BIT-moodle-2022-35649
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.
Affected packages
| Package | Versions |
|---|---|
| Packagist · moodle/moodle | introduced 3.9, fixed 3.9.15 |
| Packagist · moodle/moodle | introduced 3.11, fixed 3.11.8 |
| Packagist · moodle/moodle | introduced 4.0, fixed 4.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-35649 ADVISORY
- https://bugzilla.redhat.com/show_bug.cgi?id=2106273 WEB
- https://github.com/moodle/moodle PACKAGE
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3 WEB
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V WEB
- https://moodle.org/mod/forum/discuss.php?d=436456 WEB
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-75044 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |