GHSA-xmc8-cjfr-phx3

Regular Expression Denial of Service in highcharts

At a glance

Published
Updated
CVE
CVE-2018-20801
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

Versions of `highcharts` prior to 6.1.0 are vulnerable to Regular Expression Denial of Service (ReDoS). Untrusted input may cause catastrophic backtracking while matching regular expressions. This can cause the application to be unresponsive leading to Denial of Service. ## Recommendation Upgrade to version 6.1.0 or higher.

Affected packages

PackageVersions
npm · highchartsintroduced 0, fixed 6.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database