GHSA-xjp4-hw94-mvp5

Apache Commons Configuration: StackOverflowError adding property in AbstractListDelimiterHandler.flattenIterator()

At a glance

Published
Updated
CVE
CVE-2024-29131
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Description

This Out-of-bounds Write vulnerability in Apache Commons Configuration affects Apache Commons Configuration: from 2.0 before 2.10.1. User can see this as a 'StackOverflowError' when adding a property in 'AbstractListDelimiterHandler.flattenIterator()'. Users are recommended to upgrade to version 2.10.1, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.commons:commons-configuration2introduced 2.0, fixed 2.10.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database