GHSA-xhfx-rm8q-c3xv

Moodle Vulnerable to Reflected Cross-site Scripting

At a glance

Published
Updated
CVE
CVE-2021-20183
Aliases
BIT-moodle-2021-20183
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Description

It was found in Moodle before version 4.0.0-beta that some search inputs were vulnerable to reflected Cross-site Scripting (XSS) due to insufficient escaping of search queries.

Affected packages

PackageVersions
Packagist · moodle/moodleintroduced 3.10, fixed 4.0.0-beta

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database