GHSA-xh29-r2w5-wx8m

Nokogiri Improperly Handles Unexpected Data Type

En bref

Publiée
Mise à jour
CVE
CVE-2022-29181
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Description

### Summary Nokogiri `< v1.13.6` does not type-check all inputs into the XML and HTML4 SAX parsers. For CRuby users, this may allow specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. ### Severity The Nokogiri maintainers have evaluated this as **High 8.2** (CVSS3.1). ### Mitigation CRuby users should upgrade to Nokogiri `>= 1.13.6`. JRuby users are not affected. ### Workarounds To avoid this vulnerability in affected applications, ensure the untrusted input is a `String` by calling `#to_s` or equivalent. ### Credit This vulnerability was responsibly reported by @agustingianni and the Github Security Lab.

Paquets affectés

PaquetVersions
RubyGems · nokogiriintroduced 0, fixed 1.13.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database