GHSA-xgrm-4fwx-7qm8
pgx contains memory-safety vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-33815
- Alias
- GO-2026-4771
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
[pgx](github.com/jackc/pgx/v5) is a pure Go driver and toolkit for PostgreSQL. pgx prior to v5.9.0 contains a memory-safety vulnerability.
Paquets affectés
| Paquet | Versions |
|---|---|
| Go · github.com/jackc/pgx/v5 | introduced 0, fixed 5.9.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2026-33815 ADVISORY
- https://github.com/jackc/pgx/issues/2519 WEB
- https://github.com/jackc/pgx/issues/2530 WEB
- https://github.com/jackc/pgx/commit/6dbad4cafdb8a4daab7ff79c858c95da4b6109e8 WEB
- https://pkg.go.dev/vuln/GO-2026-4771 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |