GHSA-xgr2-v94m-rc9g

activesupport in Rails vulnerable to incorrect data conversion

At a glance

Published
Updated
CVE
CVE-2013-0333

Description

`lib/active_support/json/backends/yaml.rb` in Ruby on Rails 2.3.x before 2.3.16 and 3.0.x before 3.0.20 does not properly convert JSON data to YAML data for processing by a YAML parser, which allows remote attackers to execute arbitrary code, conduct SQL injection attacks, or bypass authentication via crafted data that triggers unsafe decoding, a different vulnerability than CVE-2013-0156.

Affected packages

PackageVersions
RubyGems · activesupportintroduced 2.3.2, fixed 2.3.16
RubyGems · activesupportintroduced 3.0.0, fixed 3.0.20

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database