GHSA-x92h-wmg2-6hp7

Invalid HTTP method overrides allow possible XSS or other attacks in Symfony

At a glance

Published
Updated
CVE
CVE-2019-10913
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, HTTP Methods provided as verbs or using the override header may be treated as trusted input, but they are not validated, possibly causing SQL injection or XSS. This is related to symfony/http-foundation.

Affected packages

PackageVersions
Packagist · symfony/http-foundationintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/http-foundationintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/http-foundationintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/http-foundationintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/http-foundationintroduced 4.2.0, fixed 4.2.7
Packagist · symfony/symfonyintroduced 2.7.0, fixed 2.7.51
Packagist · symfony/symfonyintroduced 2.8.0, fixed 2.8.50
Packagist · symfony/symfonyintroduced 3.0.0, fixed 3.4.26
Packagist · symfony/symfonyintroduced 4.0.0, fixed 4.1.12
Packagist · symfony/symfonyintroduced 4.2.0, fixed 4.2.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database