GHSA-x7hr-w5r2-h6wg

PrismJS DOM Clobbering vulnerability

At a glance

Published
Updated
CVE
CVE-2024-53382
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N

Description

Prism (aka PrismJS) through 1.29.0 allows DOM Clobbering (with resultant XSS for untrusted input that contains HTML but does not directly contain JavaScript), because document.currentScript lookup can be shadowed by attacker-injected HTML elements.

Affected packages

PackageVersions
npm · prismjsintroduced 0, fixed 1.30.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database