GHSA-x72f-ggjw-v5xh

Drupal Core Arbitrary PHP code execution vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2020-13664
Alias
BIT-drupal-2020-13664, DRUPAL-CORE-2020-005
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.8.0, fixed 8.8.8
Packagist · drupal/coreintroduced 8.9.0, fixed 8.9.1
Packagist · drupal/coreintroduced 9.0.0, fixed 9.0.1
Packagist · drupal/drupalintroduced 8.8.0, fixed 8.8.8
Packagist · drupal/drupalintroduced 8.9.0, fixed 8.9.1
Packagist · drupal/drupalintroduced 9.0.0, fixed 9.0.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database