GHSA-x5pg-88wf-qq4p
Regular Expression Denial of Service in marked
At a glance
- Published
- Updated
- CVE
- CVE-2017-16114
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Affected versions of `marked` are vulnerable to a regular expression denial of service. The amplification in this vulnerability is significant, with 1,000 characters resulting in the event loop being blocked for around 6 seconds. ## Recommendation Update to version 0.3.9 or later.
Affected packages
| Package | Versions |
|---|---|
| npm · marked | introduced 0, fixed 0.3.9 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-16114 ADVISORY
- https://github.com/chjj/marked/issues/937 WEB
- https://github.com/advisories/GHSA-x5pg-88wf-qq4p ADVISORY
- https://www.npmjs.com/advisories/531 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |