GHSA-x457-cw4h-hq5f

JSON gem has Improper Input Validation vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2013-0269

Description

The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."

Paquets affectés

PaquetVersions
RubyGems · jsonintroduced 0, fixed 1.5.5
RubyGems · jsonintroduced 1.6.0, fixed 1.6.8
RubyGems · jsonintroduced 1.7.0, fixed 1.7.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database