GHSA-x42g-82pp-4v6g
Magento SQL injection vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2019-8130
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
A SQL injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. A user with store manipulation privileges can execute arbitrary SQL queries by getting access to the database connection through group instance in email templates.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 2.2.0, fixed 2.2.10 |
| Packagist · magento/community-edition | introduced 2.3.0, fixed 2.3.2-p1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8130 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8130.yaml WEB
- https://github.com/magento/magento2 PACKAGE
- https://web.archive.org/web/20210616202033/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |