GHSA-x2q9-r8gm-f657

Drupal Core Access bypass vulnerability

At a glance

Published
Updated
CVE
CVE-2020-13667
Aliases
BIT-drupal-2020-13667, DRUPAL-CORE-2020-008
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Description

Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 8.8.0, fixed 8.8.10
Packagist · drupal/coreintroduced 8.9.0, fixed 8.9.6
Packagist · drupal/coreintroduced 9.0.0, fixed 9.0.6
Packagist · drupal/drupalintroduced 8.8.0, fixed 8.8.10
Packagist · drupal/drupalintroduced 8.9.0, fixed 8.9.6
Packagist · drupal/drupalintroduced 9.0.0, fixed 9.0.6

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database