GHSA-wxqc-pxw9-g2p8

Spring Framework vulnerable to denial of service

En bref

Publiée
Mise à jour
CVE
CVE-2023-20863
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

In Spring Framework versions prior to 5.2.24.release+ , 5.3.27+ and 6.0.8+ , it is possible for a user to provide a specially crafted Spring Expression Language (SpEL) expression that may cause a denial-of-service (DoS) condition.

Paquets affectés

PaquetVersions
Maven · org.springframework:spring-expressionintroduced 6.0.0, fixed 6.0.8
Maven · org.springframework:spring-expressionintroduced 5.3.0, fixed 5.3.27
Maven · org.springframework:spring-expressionintroduced 0, fixed 5.2.24.RELEASE

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database