GHSA-wx67-qw84-cm4g
react-server-dom: Denial of Service in Server Functions
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-44907
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
### Impact A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to out-of-memory exceptions or excessive CPU usage. We recommend updating immediately. The vulnerability exists in versions 19.0.0 through 19.0.7, 19.1.0 through 19.1.8, and 19.2.0 through 19.2.7 of: - react-server-dom-webpack - react-server-dom-parcel - react-server-dom-turbopack ### Patches Fixes were back ported to versions 19.0.8, 19.1.9, and 19.2.8. If you are using any of the above packages please upgrade to any of the fixed versions immediately. If your app’s React code does not use a server, your app is not affected by this vulnerability. If your app does not use a framework, bundler, or bundler plugin that supports React Server Components, your app is not affected by this vulnerability.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · react-server-dom-webpack | introduced 19.0.0, fixed 19.0.8 |
| npm · react-server-dom-turbopack | introduced 19.0.0, fixed 19.0.8 |
| npm · react-server-dom-turbopack | introduced 19.1.0, fixed 19.1.9 |
| npm · react-server-dom-parcel | introduced 19.1.0, fixed 19.1.9 |
| npm · react-server-dom-webpack | introduced 19.1.0, fixed 19.1.9 |
| npm · react-server-dom-turbopack | introduced 19.2.0, fixed 19.2.8 |
| npm · react-server-dom-parcel | introduced 19.2.0, fixed 19.2.8 |
| npm · react-server-dom-webpack | introduced 19.2.0, fixed 19.2.8 |
Références
- https://github.com/react/react/security/advisories/GHSA-wx67-qw84-cm4g WEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-44907 ADVISORY
- https://github.com/react/react PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |