GHSA-ww97-9w65-2crx

Improper Input Validation in Apache Solr

At a glance

Published
Updated
CVE
CVE-2019-17558
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H/E:H

Description

Apache Solr 5.0.0 to Apache Solr 8.3.1 are vulnerable to a Remote Code Execution through the VelocityResponseWriter. A Velocity template can be provided through Velocity templates in a configset `velocity/` directory or as a parameter. A user defined configset could contain renderable, potentially malicious, templates. Parameter provided templates are disabled by default, but can be enabled by setting `params.resource.loader.enabled` by defining a response writer with that setting set to `true`. Defining a response writer requires configuration API access. Solr 8.4 removed the params resource loader entirely, and only enables the configset-provided template rendering when the configset is `trusted` (has been uploaded by an authenticated user).

Affected packages

PackageVersions
Maven · org.apache.solr:solr-coreintroduced 5.0.0, fixed 8.4.0
Maven · org.apache.solr:solr-coreintroduced 6.0.0, fixed 8.4.0
Maven · org.apache.solr:solr-coreintroduced 7.0.0, fixed 8.4.0
Maven · org.apache.solr:solr-coreintroduced 8.0.0, fixed 8.4.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database