GHSA-wvhm-4hhf-97x9
Cross-Site Scripting in Prism
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2020-15138
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L
Description
### Impact The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). ### Patches This problem is patched in v1.21.0. ### Workarounds To workaround the issue without upgrading, [disable the easing preview](https://prismjs.com/plugins/previewers/#disabling-a-previewer) on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround. ### References The vulnerability was introduced by this [commit](https://github.com/PrismJS/prism/commit/4303c940d3d3a20e8ce7635bf23331c75060f5c5) on Sep 29, 2015 and fixed by [Masato Kinugawa](https://twitter.com/kinugawamasato) (#2506). ### For more information If you have any questions or comments about this advisory, please [open an issue](https://github.com/PrismJS/prism/issues).
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · prismjs | introduced 1.1.0, fixed 1.21.0 |
Références
- https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9 WEB
- https://nvd.nist.gov/vuln/detail/CVE-2020-15138 ADVISORY
- https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c WEB
- https://prismjs.com/plugins/previewers/#disabling-a-previewer WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |