GHSA-wr66-vrwm-5g5x
Denial of Service Vulnerability in next.js
At a glance
- Published
- Updated
- CVE
- CVE-2022-21721
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
### Impact Vulnerable code could allow a bad actor to trigger a denial of service attack for anyone running a Next.js app at version >= 12.0.0, and using i18n functionality. - **Affected:** All of the following must be true to be affected by this CVE - Next.js versions above v12.0.0 - Using next start or a custom server - Using the built-in i18n support - **Not affected:** - Deployments on Vercel (vercel.com) are not affected along with similar environments where invalid requests are filtered before reaching Next.js. ### Patches A patch has been released, `next@12.0.9`, that mitigates this issue. We recommend all affected users upgrade as soon as possible. ### Workarounds We recommend upgrading whether you can reproduce or not although you can ensure `/${locale}/_next/` is blocked from reaching the Next.js instance until you upgrade. ### For more information If you have any questions or comments about this advisory: * Open an issue in [next](https://github.com/vercel/next.js) * Email us at [security@vercel.com](mailto:security@vercel.com)
Affected packages
| Package | Versions |
|---|---|
| npm · next | introduced 12.0.0, fixed 12.0.9 |
References
- https://github.com/vercel/next.js/security/advisories/GHSA-wr66-vrwm-5g5x WEB
- https://nvd.nist.gov/vuln/detail/CVE-2022-21721 ADVISORY
- https://github.com/vercel/next.js/pull/33503 WEB
- https://github.com/vercel/next.js PACKAGE
- https://github.com/vercel/next.js/releases/tag/v12.0.9 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |