GHSA-wpr6-qvcq-8269
Stored Cross-site Scripting vulnerability in Jenkins Subversion Plugin
At a glance
- Published
- Updated
- CVE
- CVE-2022-29046
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
Jenkins Subversion Plugin 2.15.3 and earlier does not escape the name and description of List Subversion tags (and more) parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the [SECURITY-353 / CVE-2017-2601](https://www.jenkins.io/security/advisory/2017-02-01/#persisted-cross-site-scripting-vulnerability-in-parameter-names-and-descriptions) fix.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.plugins:subversion | introduced 0, fixed 2.15.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-29046 ADVISORY
- https://github.com/jenkinsci/subversion-plugin PACKAGE
- https://support.apple.com/kb/HT213345 WEB
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617 WEB
- http://seclists.org/fulldisclosure/2022/Jul/18 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |