GHSA-wpfp-q843-v772

Cross-site Scripting in moodle

En bref

Publiée
Mise à jour
CVE
CVE-2021-43558
Alias
BIT-moodle-2021-43558
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 3.11.0, fixed 3.11.4
Packagist · moodle/moodleintroduced 3.10.0, fixed 3.10.8
Packagist · moodle/moodleintroduced 3.9.0, fixed 3.9.11

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database