GHSA-wmr8-25ff-ggpj
Incorrect Authorization in Jenkins
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-1999004
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Description
A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.121.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.122, fixed 2.132 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999004 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/40250f08aca7f3f8816f21870ee23463a52ef2f2 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-892 WEB
- https://www.oracle.com/security-alerts/cpuapr2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |