GHSA-wm86-w3cf-h6vm

Drupal external link injection vulnerability

At a glance

Published
Updated
CVE
CVE-2017-6932
CVSS_V3
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Drupal core 7.x versions before 7.57 has an external link injection vulnerability when the language switcher block is used. A similar vulnerability exists in various custom and contributed modules. This vulnerability could allow an attacker to trick users into unwillingly navigating to an external site.

Affected packages

PackageVersions
Packagist · drupal/coreintroduced 7.0, fixed 7.57
Packagist · drupal/drupalintroduced 7.0, fixed 7.57

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database