GHSA-wg4g-wm44-ch5j
Pion DTLS vulnerable to denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-54908
- Alias
- GO-2026-6165
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
Description
### Impact Remote denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message. ### Patches Upgrade to v3.1.4 or later. This version includes this patch https://github.com/pion/dtls/pull/839 which fixes the issue. ### Workarounds No work around; please upgrade to v3.1.4 or a newer version.
Paquets affectés
| Paquet | Versions |
|---|---|
| Go · github.com/pion/dtls/v3 | introduced 0, fixed 3.1.4 |
Références
- https://github.com/pion/dtls/security/advisories/GHSA-wg4g-wm44-ch5j WEB
- https://nvd.nist.gov/vuln/detail/CVE-2026-54908 ADVISORY
- https://github.com/pion/dtls/pull/839 WEB
- https://github.com/pion/dtls/commit/49458d604a4f3ebce1bf9587a0f3e5f3f6b4a55e WEB
- https://github.com/pion/dtls PACKAGE
- https://github.com/pion/dtls/releases/tag/v3.1.3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |