GHSA-wf9g-rh76-6jvr
Incorrect Permission Assignment for Critical Resource in Jenkins
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2017-2612
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
Description
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to override JDK download credentials (SECURITY-392), resulting in future builds possibly failing to download a JDK.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.32.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.34, fixed 2.44 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2017-2612 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/a814154695e23dc37542af7d40cacc129cf70722 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2612 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2017-02-01 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |