GHSA-w9m9-85wc-3x92

postcss-selector-parser allows denial of service through uncontrolled AST recursion

At a glance

Published
Updated
CVE
CVE-2026-9358
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P

Description

A vulnerability was determined in postcss-selector-parser before 6.1.3 and 7.1.1. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)."

Affected packages

PackageVersions
npm · postcss-selector-parserintroduced 6.1.0, fixed 6.1.3
npm · postcss-selector-parserintroduced 7.1.0, fixed 7.1.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database