GHSA-w7cp-g8v7-r54m

Apache Airflow Cross-site Scripting Vulnerability

At a glance

Published
Updated
CVE
CVE-2024-41937
Aliases
BIT-airflow-2024-41937, PYSEC-2024-181
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 0, fixed 2.10.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database