GHSA-w5v7-q2j4-fvpf
Jenkins Cross-site Scripting vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2015-1812
Description
Cross-site scripting (XSS) vulnerability in Jenkins before 1.606 and LTS before 1.596.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2015-1813.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.596.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.600, fixed 1.606 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1812 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/f58ba6e72f978e2f73299e38a1b54ff70fc73fd8 WEB
- https://github.com/jenkinsci/jenkins/commit/f880d8d2cd9d46987ee3630fa04f77b17784f4e8 WEB
- https://github.com/jenkinsci/jenkins/commit/feb2703adb0c121705e5c8e9ddf8f663b6481cbd WEB
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1205615 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-03-23 WEB
- http://rhn.redhat.com/errata/RHSA-2015-1844.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |