GHSA-w457-6q6x-cgp9
Prototype Pollution in handlebars
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-19919
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Versions of `handlebars` prior to 3.0.8 or 4.3.0 are vulnerable to Prototype Pollution leading to Remote Code Execution. Templates may alter an Objects' `__proto__` and `__defineGetter__` properties, which may allow an attacker to execute arbitrary code through crafted payloads. ## Recommendation Upgrade to version 3.0.8, 4.3.0 or later.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · handlebars | introduced 4.0.0, fixed 4.3.0 |
| RubyGems · bootstrap-wysihtml5-rails | introduced 0.3.3.5, last affected 0.3.3.8 |
| npm · handlebars | introduced 0, fixed 3.0.8 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2019-19919 ADVISORY
- https://github.com/wycats/handlebars.js/issues/1558 WEB
- https://github.com/handlebars-lang/handlebars.js/commit/156061eb7707575293613d7fdf90e2bdaac029ee WEB
- https://github.com/handlebars-lang/handlebars.js/commit/90ad8d97ad2933852fb83fcc054699dc99e094db WEB
- https://github.com/wycats/handlebars.js/commit/2078c727c627f25d4a149962f05c1e069beb18bc WEB
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19919 WEB
- https://github.com/Nerian/bootstrap-wysihtml5-rails/blob/master/vendor/assets/javascripts/bootstrap-wysihtml5/handlebars.runtime.min.js WEB
- https://github.com/Nerian/bootstrap-wysihtml5-rails/tree/master/vendor/assets/javascripts/bootstrap-wysihtml5 WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/bootstrap-wysihtml5-rails/CVE-2019-19919.yml WEB
- https://github.com/wycats/handlebars.js PACKAGE
- https://www.tenable.com/security/tns-2021-14 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |