GHSA-vpw3-3prf-3974
Apache Hive Code Injection vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2023-35701
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.hive:hive-jdbc | introduced 4.0.0-alpha-1, fixed 4.0.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-35701 ADVISORY
- https://github.com/apache/hive/commit/7abeb1df463cc389f668172e7cf3bb772799858a WEB
- https://github.com/apache/hive PACKAGE
- https://issues.apache.org/jira/browse/HIVE-27554 WEB
- https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81 WEB
- http://www.openwall.com/lists/oss-security/2024/05/03/3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |