GHSA-vp98-w2p3-mv35

Apache Log4j 1.x (EOL) allows Denial of Service (DoS)

At a glance

Published
Updated
CVE
CVE-2023-26464
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

** UNSUPPORTED WHEN ASSIGNED ** When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Affected packages

PackageVersions
Maven · org.apache.logging.log4j:log4j-coreintroduced 1.0.4, fixed 2.0
Maven · log4j:log4jintroduced 1.0.4, fixed 2.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database