GHSA-vp37-2f9p-3vr3
Cross-site Scripting in OWASP AntiSamy
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-29577
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Description
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. OWASP AntiSamy before 1.6.7 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content. NOTE: this issue exists because of an incomplete fix for CVE-2022-28367.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.owasp.antisamy:antisamy | introduced 0, fixed 1.6.7 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-29577 ADVISORY
- https://github.com/nahsra/antisamy/commit/32e273507da0e964b58c50fd8a4c94c9d9363af0 WEB
- https://github.com/nahsra/antisamy PACKAGE
- https://github.com/nahsra/antisamy/releases/tag/v1.6.7 WEB
- https://www.oracle.com/security-alerts/cpujul2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |