GHSA-vmfx-gcfq-wvm2
Nokogiri implementation of libxslt vulnerable to heap corruption
At a glance
- Published
- Updated
- CVE
- CVE-2019-5815
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
Type confusion in `xsltNumberFormatGetMultipleLevel` prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data. Nokogiri prior to version 1.10.5 contains a vulnerable version of libxslt. Nokogiri version 1.10.5 upgrades the dependency to libxslt 1.1.34, which contains a patch for this issue.
Affected packages
| Package | Versions |
|---|---|
| RubyGems · nokogiri | introduced 0, fixed 1.10.5 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-5815 ADVISORY
- https://github.com/sparklemotion/nokogiri/issues/2630 WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-5815.yml WEB
- https://github.com/sparklemotion/nokogiri PACKAGE
- https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b WEB
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |