GHSA-vm5m-qmrx-fw8w

Apache Airflow: Bypass permission verification to read code of other dags

En bref

Publiée
Mise à jour
CVE
CVE-2023-50944
Alias
BIT-airflow-2023-50944, PYSEC-2024-14
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.8.1rc1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database