GHSA-vj6q-v2h7-6q5m
Jenkins cross-site scripting (XSS) vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2014-2067
Description
Cross-site scripting (XSS) vulnerability in java/hudson/model/Cause.java in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users to inject arbitrary web script or HTML via a "remote cause note."
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.533, fixed 1.551 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.532.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2014-2067 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/5d57c855f3147bfc5e7fda9252317b428a700014 WEB
- https://exchange.xforce.ibmcloud.com/vulnerabilities/91354 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-02-14 WEB
- http://seclists.org/oss-sec/2014/q1/421 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |