GHSA-vghf-hv5q-vc2g
Validator is Vulnerable to Incomplete Filtering of One or More Instances of Special Elements
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-12758
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Description
Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · validator | introduced 0, fixed 13.15.22 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-12758 ADVISORY
- https://github.com/validatorjs/validator.js/pull/2616 WEB
- https://github.com/validatorjs/validator.js/commit/d457ecaf55b0f3d8bd379d82757425d0d13dd382 WEB
- https://gist.github.com/koral--/ad31208b25b9e3d1e2e35f1d4d72572e WEB
- https://github.com/validatorjs/validator.js PACKAGE
- https://security.snyk.io/vuln/SNYK-JS-VALIDATOR-13653476 WEB
- http://seclists.org/fulldisclosure/2026/Jan/27 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |