GHSA-vg3r-rm7w-2xgh

REXML contains a denial of service vulnerability

At a glance

Published
Updated
CVE
CVE-2024-35176
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Description

### Impact The REXML gem before 3.2.6 has a DoS vulnerability when it parses an XML that has many `>`s in an attribute value. If you need to parse untrusted XMLs, you may be impacted to this vulnerability. ### Patches The REXML gem 3.2.7 or later include the patch to fix this vulnerability. ### Workarounds Don't parse untrusted XMLs. ### References * https://www.ruby-lang.org/en/news/2024/05/16/dos-rexml-cve-2024-35176/

Affected packages

PackageVersions
RubyGems · rexmlintroduced 0, fixed 3.2.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database