GHSA-vg35-5wq7-3x7w

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

At a glance

Published
Updated
CVE
CVE-2026-47761
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Description

### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted `data-mce-*` attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.5.1, TinyMCE 7.9.3 and TinyMCE 5.11.1 LTS by ensuring that, when using the media plugin, any content with `data-mce-object` and `data-mce-p-*` attributes are properly sanitized. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: - Upgrade to TinyMCE 8.5.1 or higher. - Upgrade to TinyMCE 7.9.3 or higher. - Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial [long-term support](https://www.tiny.cloud/long-term-support/) contract). ### Acknowledgements Tiny thanks [Aymane MAZGUITI](https://github.com/UncleJ4ck) and [Ange Primiterra](https://github.com/ange-primiterra) for their help identifying this vulnerability.

Affected packages

PackageVersions
npm · tinymceintroduced 0, last affected 5.10.9
npm · tinymceintroduced 6.0.0, fixed 7.9.3
npm · tinymceintroduced 8.0.0, fixed 8.5.1
NuGet · TinyMCEintroduced 0, last affected 5.10.9
NuGet · TinyMCEintroduced 6.0.0, fixed 7.9.3
NuGet · TinyMCEintroduced 8.0.0, fixed 8.5.1
Packagist · tinymce/tinymceintroduced 0, last affected 5.10.9
Packagist · tinymce/tinymceintroduced 6.0.0, fixed 7.9.3
Packagist · tinymce/tinymceintroduced 8.0.0, fixed 8.5.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database