GHSA-vfm7-4h43-gp6m

Duplicate Advisory: vLLM Vulnerable to Regular Expression Denial of Service

Withdrawn ·

At a glance

Published
Updated
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Description

### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-j828-28rj-hfhp. This link is maintained to preserve external references. ### Original Description vLLM versions >= 0.6.3 and < 0.9.0 contain multiple regular expression denial of service (ReDoS) vulnerabilities. Several regex patterns — in vllm/lora/utils.py, the phi4mini tool parser, and the OpenAI-compatible serving chat endpoint — are susceptible to catastrophic backtracking. An attacker submitting crafted input with nested or repeated structures can trigger severe CPU consumption and performance degradation, resulting in denial of service.

Affected packages

PackageVersions
PyPI · vllmintroduced 0.6.3, fixed 0.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database