GHSA-vcf6-3wv2-5vcr
Apache Airflow vulnerable to stored Cross-site Scripting
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-29247
- Alias
- BIT-airflow-2023-29247, PYSEC-2023-60
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Description
Task instance details page in the UI is vulnerable to stored cross-site scripting. This issue affects Apache Airflow before 2.6.0.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.6.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-29247 ADVISORY
- https://github.com/apache/airflow/pull/30447 WEB
- https://github.com/apache/airflow/pull/30779 WEB
- https://github.com/apache/airflow/commit/46c85ec11d224c133da6c45c1186c9aa498a7e75 WEB
- https://github.com/apache/airflow/commit/f819dfcb24c597058b7b671f6317e4c84976975e WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-60.yaml WEB
- https://lists.apache.org/thread/kqf5lxmko133780clsp827xfsh4xd3fl WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |